Weather Defender Documentation

Page History: Main Interface

Compare Page Revisions



« Older Revision - Back to Page History - Newer Revision »


Page Revision: 12/26/2008 8:48 PM


This page describes the main application interface including toolbars, buttons, and dialog windows in Weather Defender.

Weather Defender was designed with simplicity in mind. It takes only a few minutes to learn basic navigation, and you do not need to understand every tool and function in order to use the application.

But under the covers, there is a lot of functionality that will enhance your experience. The following documentation is a complete reference to every button and function in the main interface.

Weather Defender Main Interface

Weather Defender Main Interface

Table of Contents [Hide/Show]


1 - Interface Overview

The main interface is divided up into four parts: toolbars, workspace, dialog windows, and status bar.

Interface Components

Interface Components




1.1 - Workspace

The Workspace is the part of the interface where you will interact with your Map.

Map being displayed in the Workspace area

Map being displayed in the Workspace area




Using navigation tools, you can reposition the Map and zoom the Map to your desired location.

Use navigation tools to reposition the Map

Use navigation tools to reposition the Map




Using the Map Layers Dialog Window, you may select what is displayed on your Map.

Use the Map Layers Dialog to select which layers should be displayed on your Map

Use the Map Layers Dialog to select which layers should be displayed on your Map




Layers in a Map are represented as a vertical stack. Bottom layers are displayed "under" top-most layers. Layers can be rearranged in the Map Layers Dialog Window.

Layers are represented as a vertical stack

Layers are represented as a vertical stack




There are many tools which can be utilized in the Map/Workspace area, each with its own function. See the Map Tab - "Tools" section for more.



1.2 - Toolbars

The top portion of the interface contains all the tools and functions available to you.

Toolbar Components

Toolbar Components


Most of the tools are grouped in Tabs and Specialized Menus for easier reference.



Map Tab

This menu provides functionality that relates to your map: navigation, layers, drawing, etc.

Map Tab

Map Tab


Map Tab - "Project" Functions:

Weather Defender uses a Document-style method for storing Map customizations. Like in Microsoft Word, you start with a blank template Map. You can modify that Map by adding or removing layers, or repositioning the view. You can save changes to your Map as a file on your computer. You can even share your Maps with other Weather Defenders. The idea is to permit you to create multiple maps for multiple purposes, and be able to later recall those maps just as you would documents written in a word processor.

New Map

Open a new blank Map. If a Map is already open, the new Map will be displayed in a separate tab in the Workspace.

Open

Open a previously saved Map from your computer. Map will display in a separate Workspace tab if another Map is already open.

Save

Save changes to the current Map. Will store changes to the same location where Map was loaded from. To save to an alternate location, use the "Save As" function in the "Shield Menu".


Map Tab - "Tool" Functions:

This section provides tools that directly interact with the Map.

Create Perimeter

Use this tool to draw a circular perimeter around a position you want to monitor for severe weather. With the tool selected, click and hold the left mouse button on the center of the area you want to monitor, and drag the mouse in any direction to create the perimeter as large as desired. Then release the left mouse button and enter the threat information on the window that pops up.

Measure

Draw a line over the map to measure the distance in miles between two points. Note, for performance reasons a simple algorithm was used to calculate mileage and is less accurate over large distances. The measure tool is more accurate when measuring distances less than 200 miles.

Forecast

Use this tool to get a 7-day forecast anywhere in the continental United States by simply clicking on the map.

Set Home

Allows you to change your "Home" position by clicking another location on the map. The Home location is both for your own reference when monitoring the weather, and also for displaying your position to other Weather Defenders when you join a Chat room.

Add Point

Add a point of interest to your the Map.

Draw Line

Draw a line on your Map.

Clear Drawings

Clears all points and lines drawn on your Map.

Export Drawings

Save your drawings as a separate GIS layer. This allows you to import drawings between Maps, as well as use drawings from Weather Defender in other GIS applications.


Map Tab - "Navigate" Functions:
Pan/Zoom

This is the primary tool you will use in Weather Defender. When selected, your cursor will appear as a Hand when over the Map. Click and hold the left mouse button to "drag" (pan) the Map to a new position. Click and hold the right mouse button to zoom the map in or out.

Zoom Box

Allows you to left click and draw a box over the region you want to zoom to. Alternately with this tool, left clicking once or right clicking once will zoom the map in or out one level.

Back

Repositions the Map to the previous position. Functions like an "Undo" for Map positioning.

Next

If Back was clicked, the Next button allows you to revert the position to what was displayed before you clicked Back. Functions like "Redo".

Presets

The Presets menu allows you to reposition the Map to a previously stored location.

Presets Menu

Presets Menu


Center Home

Center the Map on your Home position.

(Preset Name)

Reposition the Map to the corresponding location (see Save Current).

Save Current

Allows you to store the current Map view as a new preset. Just type in the nickname you want assigned with this view and press Enter. The preset should appear as a new menu item.

Clear List

Deletes all stored presets.


Map Tab - "Layer" Functions:

Add Layer

This menu provides access to all of the Weather and Geographic Layers that can be added to your Map.

Layer Menu

Layer Menu


Recent

This submenu provides access to recently-added Layers.

(Layer Name)

Click on one of the Weather or Geography Layers in this menu to add that Layer to your map. If the Layer does not currently exist on your computer (or the data is not current), it will be automatically downloaded from a central server. The newly added Layer will be represented by a new button in the Map Layers Dialog Window.

Browse Layers

Launch the Layer Browser: Our complete and continually expanding library of Weather, Geography, and other types of Layers which can be added to your Map.

From Disk

Add a Layer from your computer. Must be one of the following supported GIS formats:
*.GRD; *.ADF; *.E00; *.FLT; *.SHP; *.DXF; *.BT; *.TOC; *.RT1; *.DEM; *.DLF; *.OPT; *.DT0; *.DT1; *.DT2; *.ECW; *.IMG; *.GDF; *.GML; *.XML; *.KML; *.GPX; *.GIF; *.JP2; *.J2K; *.JPX; *.JPC; *.JPG; *.JPEG; *.SID; *.MIF; *.TAB; *.DGN; *.PNG; *.DDF; *.BIL; *.TIF; *.TIFF; *.TTKPS; *.TTKLS; *.LFT; *.PFT; *.TFT; *.BMP or *.Layer



Add Group

Create a new grouping in the Map Layers Dialog Window for organizing Layers. See Organizing Layers topic.

Back Color

Set the background color of the Map. If no foreground layers are covering the oceans, this will change the color of the oceans.

Palette Editor

Launches the Palette Editor for customizing colors used in Radar and Layer Effects. See Editing Color Palettes topic.



Map Tab - "Capture" Functions:

Screenshot

Save a screenshot of the current Map as a GIF, PNG, TIFF, or BMP on your computer.

(Screenshot Menu) > Start Timed Captures

When enabled, a screenshot will be taken automatically every xx minutes.

(Screenshot Menu) > Settings

Loads the screen capture settings including dimensions, file type, labeling effects, and FTP information for automated upload of screenshots to a remote web server. See Screen Capturing topic.

Animate

Launches the Map Animator in a separate window animating the history of weather imagery associated with the current Map. Animation history starts when the Map was first loaded.

(Animate Menu) > Reset Animation

Clears animation history, resetting the start time of the animation to the present time.

(Animate Menu) > Settings

Loads the animation capture settings including dimensions, frame interval, and labeling effects. See Animating topic.




Team Tab

This menu contains functions for collaborating with other Weather Defenders, as well as maintainin your account information (profile and billing).

Team Tab

Team Tab


Team Tab - "Collaborate" Functions:

Chat

Log in to the group chat rooms to chat with other Weather Defenders presently online.

Reconnect

Re-establish the chat connection if there is a connection error.

Disconnect

Log out of the chat rooms.

Chat Rooms

View a listing of available chat rooms, or create a new one.

Share View

Sends your current Map View (coordinates) to everyone in the chat room, so they may reposition to what you are looking at.

Place Marker

Add a marker to everyone's map in the chat room, highlighting a point of interest.


Team Tab - "Profile" Functions:
(Profile Info)

Your selected Avatar, Username and Rank are displayed.

Status

Enter your "status" for members of the chat room to read what you are currently doing.

Account Settings

Menu containing Account options:

Profile Details

Edit basic profile information such as Name, E-mail, Bio, and change password.

Billing & Upgrades

Upgrade or cancel your subscription or sign up for premium products.

Refresh Profile

Reload profile information in the Team menu.


Team Tab - "Position" Functions:
Start GPS

Activate (or deactivate) GPS tracking. No special settings need to be made prior to activating. Automatic scan will be performed to try to locate and connect to GPS device.


Interface Tab

This menu contains functions for customizing the appearance of the application.

Team Tab

Team Tab


Interface Tab - "Dialog Windows" Functions:
Layers

Show/hide Map Layers window

Legend

Show/hide Map Legend window.

Chat

Show/hide Chat window.

GPS

Show/hide GPS window.

Dialog Settings

Menu for modifying the appearance of Dialog Windows.

Graphics Quality

Set the rendering quality of the Dialog Windows: Low, Medium, Medium High (default), or High. The High setting adds animated fade in/out.

Transparency

Set the Minimum and Maximum transparency for when the Dialog Window is active/inactive.

Reset Positions

Restore all Dialog Windows to their original positions and sizes.


Interface Tab - "Themes" Functions:
Theme Menu

Customize the main application colors by picking from 3 themes: Black (default), Blue, or Silver.

Custom Color

Modify the selected theme by tinting with another color.


Interface Tab - "Effects" Functions:
Sound

Enable/disable application sound effects.

Animated Icons

Enable/disable animated icons associated with certain layers.


Help Tab

This menu provides guidance and support functions.

Team Tab

Team Tab


Help Tab - "Guidance" Functions:
Documentation

Load main program documentation.

Video Tutorials

Watch narrated, video tutorials of common program features.

Frequently Asked Questions

Review answers to the most commonly asked questions.


Help Tab - "Support" Functions:
Forums

Load User Forums to ask questions and discuss features of Weather Defender with other users and staff.

Ask Us a Question

Simple feedback form to send a question to the Weather Defender support staff.

Contact Info

Contact options for getting in touch with Weather Defender support staff.



Help Tab - "Restore" Functions:
Reload Map

Reload the active Map in case it has become locked and will not respond to interaction.

Reset Dialogs

Reset Dialog Window locations to their original positions and sizes.




Specialized Menus

Additional functionality is available through specialized menus.

Shield Menu

The Shield Menu can be considered the "File Menu". It contains standard File Menu-type options as found in other Windows applications:

Shield Menu

Shield Menu


Shield Menu Functions:
New Map

Open a new Map using the default template.

Open Map

Open a previously saved Map (*.map) from your computer.

Save Map

Save the currently open Map to your computer.

Save Map As

Save the currently open Map to a different location on your computer.

Close Map

Close the currently open Map without shutting down the application. If more than one Map is open, only the currently active (selected) Map will be closed.

Recent Maps

Listing of most recently opened maps. Click an item to open the Map.

Exit Application

Shutdown application.


Quick Access Toolbar

The Quick Access Toolbar (QAT) is an always-visible menu where you can store shortcuts to frequently-used functions in other menus.

Quick Access Toolbar

Quick Access Toolbar


QAT Menu Functions (Default):
Save Map

Save the currently open Map to your computer.

Previous View

Repositions the Map to the last-viewed extent.
Customizing the QAT

To add functions to the QAT, right-click any button in the Tab or Shield Menus, and select 'Add to Quick Access Toolbar'.

To remove functions from the QAT, right-click the function you want to remove in the QAY, and select 'Remove from Quick Access Toolbar'.



1.3 - Dialog Windows

Dialog Windows are the semi-transparent windows that appear over top of the workspace area. By default, only the Map Layers and Legend Dialog Windows will be shown. Taking certain actions in the application will cause other Dialog Windows to appear. For example, activating a GPS connection will cause the GPS Dialog Window to be displayed with status information.

There are five Dialog Windows in total: Map Layers, Map Legend, GPS, Chat, and Info Dialogs.

Map Layers

Map Legend

GPS

Chat

Info

Info Dialogs are temporary pop-up windows that display when you click special icons on the map workspace. Certain data sets contain more details than can be displayed on-screen. For example, Storm Reports about snowfall would be displayed as a snowflake icon on the map. Clicking on this icon would pop-up an Info Dialog containing additional details (if any) such as total snowfall accumulation in the past 24 hours.

1.4 - Status Bar

The Status Bar contains real-time status information about the application.
Status Bar

Status Bar


There are 3 components:

Status Messages

General status information indicating current program activity and error messages.

Mouse Coordinates

Current latitude and longitude of the mouse cursor.

Zoom Scale

Zoom scale of current map view. 1:10 = 10 pixels per degree, 1:100 = 100 pixels per degree.




2 - Customizing the Interface

The interface is highly customizable and can be modified to suit your exact preferences.



2.1 - Color & Themes

The application shell (main window) is Black by default, but this theme can be changed to Blue or Silver using the Interface Tab > Themes menu. You may further tint a selected theme using the Custom Color option.



2.2 - Dialog Window Placement

Snapping a Dialog Window to the Workspace Edge

Snapping a Dialog Window to the Workspace Edge

All Dialog Windows can be moved to any position on the Windows Desktop by left-clicking in the title area of the window and dragging, just as you would any other application in Windows. Dialog Windows will remain fixed at the position you drag them unless they are "snapped" to the border of the workspace area, in which case they will move with the main application whenever it is moved.

A Dialog Window may be "snapped" to the workspace area by dragging it within 5 pixels of the top, bottom, left, or right of the workspace edge (see image).

Additionally, you may "dock" a Dialog Window to the top, bottom, left, or right of the workspace area to cause it to resize accordingly whenever the main application is resized. To "dock" a Dialog Window, first snap it to the desired corner of the workspace. Then resize the height (or width) of the dialog to the opposite corner of the workspace.

Dialog Window modifications will be stored when you exit the program so they will reappear in the same location the next time you start.

You may RESET all Dialog Window positions to their original locations by clicking Interface > Dialog Settings > Reset Positions.



2.3 - Maximizing Workspace

If you are not frequently interacting with the map, it may be desirous to hide the parts of the interface and maximize the workspace (map) area.

Here's how:

1. Set the toolbar menu to auto-hide: Click the purple "Pin" button in the upper-right of the application. This will minimize the toolbars when not in use.

2. Make the Dialog Windows invisible: Click Interface Tab > Dialog Settings > Transparency. Move the slider to 10 or lower to make the Dialog Windows almost or entirely invisible when not in use. Now the Dialog Windows will only appear when you move your mouse into their region of the screen.

3. Maximize the Application Window: (optional) Click the Maximize button in the upper right of the main window to increase the workspace to the maximum possible for your screen.

Maximized Workspace

Maximized Workspace


Weather Defender® - Desktop Weather Software for your PC. Weather Satellite, Weather Radar, and Street-Level Weather Tracking.



Images and text Copyright © 2008-2009 by SWIFT Weather. All rights reserved. ScrewTurn Wiki version 2.0.35. Administration | File Management