Weather Defender Documentation

Page History: Main Interface

Compare Page Revisions



« Older Revision - Back to Page History - Newer Revision »


Page Revision: 12/25/2008 7:21 AM


This page describes the main application interface including toolbars, buttons, and dialog windows in Weather Defender.

Weather Defender Main Interface

Weather Defender Main Interface

Table of Contents [Hide/Show]


Weather Defender was designed with simplicity in mind. It takes only a few minutes to learn basic navigation, and you do not need to understand every tool and function in order to use the application.

But under the covers, there is a lot of functionality that will enhance your experience. The following documentation is a complete reference to every button and function in the main interface.

1 - Interface Overview

The main interface is divided up into four parts: toolbars, workspace, dialog windows, and status bar.

Interface Components

Interface Components




1.1 - Toolbars

The top portion of the interface contains all the tools and functions available to you.

Toolbar Components

Toolbar Components


Most of the tools are grouped in Tabs and Specialized Menus for easier reference.



Map Tab

Map Tab

Map Tab


Team Tab

This menu contains functions for collaborating with other Weather Defenders, as well as maintainin your account information (profile and billing).

Team Tab

Team Tab


Team Tab - "Collaborate" Functions:

Chat

Log in to the group chat rooms to chat with other Weather Defenders presently online.

Reconnect

Re-establish the chat connection if there is a connection error.

Disconnect

Log out of the chat rooms.

Chat Rooms

View a listing of available chat rooms, or create a new one.

Share View

Sends your current Map View (coordinates) to everyone in the chat room, so they may reposition to what you are looking at.

Place Marker

Add a marker to everyone's map in the chat room, highlighting a point of interest.


Team Tab - "Profile" Functions:
(Profile Info)

Your selected Avatar, Username and Rank are displayed.

Status

Enter your "status" for members of the chat room to read what you are currently doing.

Account Settings

Menu containing Account options:

Profile Details

Edit basic profile information such as Name, E-mail, Bio, and change password.

Billing & Upgrades

Upgrade or cancel your subscription or sign up for premium products.

Refresh Profile

Reload profile information in the Team menu.


Team Tab - "Position" Functions:
Start GPS

Activate (or deactivate) GPS tracking. No special settings need to be made prior to activating. Automatic scan will be performed to try to locate and connect to GPS device.


Interface Tab

This menu contains functions for customizing the appearance of the application.

Team Tab

Team Tab


Interface Tab - "Dialog Windows" Functions:
Layers

Show/hide Map Layers window

Legend

Show/hide Map Legend window.

Chat

Show/hide Chat window.

GPS

Show/hide GPS window.

Dialog Settings

Menu for modifying the appearance of Dialog Windows.

Graphics Quality

Set the rendering quality of the Dialog Windows: Low, Medium, Medium High (default), or High. The High setting adds animated fade in/out.

Transparency

Set the Minimum and Maximum transparency for when the Dialog Window is active/inactive.

Reset Positions

Restore all Dialog Windows to their original positions and sizes.


Interface Tab - "Themes" Functions:
Theme Menu

Customize the main application colors by picking from 3 themes: Black (default), Blue, or Silver.

Custom Color

Modify the selected theme by tinting with another color.


Interface Tab - "Effects" Functions:
Sound

Enable/disable application sound effects.

Animated Icons

Enable/disable animated icons associated with certain layers.


Help Tab

This menu provides guidance and support functions.

Team Tab

Team Tab


Help Menu - "Guidance" Functions:
Documentation

Load main program documentation.

Video Tutorials

Watch narrated, video tutorials of common program features.

Frequently Asked Questions

Review answers to the most commonly asked questions.


Help Menu - "Support" Functions:
Forums

Load User Forums to ask questions and discuss features of Weather Defender with other users and staff.

Ask Us a Question

Simple feedback form to send a question to the Weather Defender support staff.

Contact Info

Contact options for getting in touch with Weather Defender support staff.



Help Menu - "Restore" Functions:
Reload Map

Reload the active Map in case it has become locked and will not respond to interaction.

Reset Dialogs

Reset Dialog Window locations to their original positions and sizes.




Specialized Menus

Additional functionality is available through specialized menus.

Shield Menu

The Shield Menu can be considered the "File Menu". It contains standard File Menu-type options as found in other Windows applications:

Shield Menu

Shield Menu


Shield Menu Functions:
New Map

Open a new Map using the default template.

Open Map

Open a previously saved Map (*.map) from your computer.

Save Map

Save the currently open Map to your computer.

Save Map As

Save the currently open Map to a different location on your computer.

Close Map

Close the currently open Map without shutting down the application. If more than one Map is open, only the currently active (selected) Map will be closed.

Recent Maps

Listing of most recently opened maps. Click an item to open the Map.

Exit Application

Shutdown application.


Quick Access Toolbar

The Quick Access Toolbar (QAT) is an always-visible menu where you can store shortcuts to frequently-used functions in other menus.

Quick Access Toolbar

Quick Access Toolbar


QAT Menu Functions (Default):
Save Map

Save the currently open Map to your computer.

Previous View

Repositions the Map to the last-viewed extent.
Customizing the QAT

To add functions to the QAT, right-click any button in the Tab or Shield Menus, and select 'Add to Quick Access Toolbar'.

To remove functions from the QAT, right-click the function you want to remove in the QAY, and select 'Remove from Quick Access Toolbar'.



1.2 - Workspace

1.3 - Dialog Windows

Dialog Windows are the semi-transparent windows that appear over top of the workspace area. By default, only the Map Layers and Legend Dialog Windows will be shown. Taking certain actions in the application will cause other Dialog Windows to appear. For example, activating a GPS connection will cause the GPS Dialog Window to be displayed with status information.

There are five Dialog Windows in total: Map Layers, Map Legend, GPS, Chat, and Info Dialogs.

Map Layers

Map Legend

GPS

Chat

Info

Info Dialogs are temporary pop-up windows that display when you click special icons on the map workspace. Certain data sets contain more details than can be displayed on-screen. For example, Storm Reports about snowfall would be displayed as a snowflake icon on the map. Clicking on this icon would pop-up an Info Dialog containing additional details (if any) such as total snowfall accumulation in the past 24 hours.

1.4 - Status Bar

The Status Bar contains real-time status information about the application.
Status Bar

Status Bar


There are 3 components:

Status Messages

General status information indicating current program activity and error messages.

Mouse Coordinates

Current latitude and longitude of the mouse cursor.

Zoom Scale

Zoom scale of current map view. 1:10 = 10 pixels per degree, 1:100 = 100 pixels per degree.




2 - Customizing the Interface

The interface is highly customizable and can be modified to suit your exact preferences.



2.1 - Color & Themes

The application shell (main window) is Black by default, but this theme can be changed to Blue or Silver using the Interface Tab > Themes menu. You may further tint a selected theme using the Custom Color option.



2.2 - Dialog Window Placement

Snapping a Dialog Window to the Workspace Edge

Snapping a Dialog Window to the Workspace Edge

All Dialog Windows can be moved to any position on the Windows Desktop by left-clicking in the title area of the window and dragging, just as you would any other application in Windows. Dialog Windows will remain fixed at the position you drag them unless they are "snapped" to the border of the workspace area, in which case they will move with the main application whenever it is moved.

A Dialog Window may be "snapped" to the workspace area by dragging it within 5 pixels of the top, bottom, left, or right of the workspace edge (see image).

Additionally, you may "dock" a Dialog Window to the top, bottom, left, or right of the workspace area to cause it to resize accordingly whenever the main application is resized. To "dock" a Dialog Window, first snap it to the desired corner of the workspace. Then resize the height (or width) of the dialog to the opposite corner of the workspace.

Dialog Window modifications will be stored when you exit the program so they will reappear in the same location the next time you start.

You may RESET all Dialog Window positions to their original locations by clicking Interface > Dialog Settings > Reset Positions.



2.3 - Maximizing Workspace

If you are not frequently interacting with the map, it may be desirous to hide the parts of the interface and maximize the workspace (map) area.

Here's how:

1. Set the toolbar menu to auto-hide: Click the purple "Pin" button in the upper-right of the application. This will minimize the toolbars when not in use.

2. Make the Dialog Windows invisible: Click Interface Tab > Dialog Settings > Transparency. Move the slider to 10 or lower to make the Dialog Windows almost or entirely invisible when not in use. Now the Dialog Windows will only appear when you move your mouse into their region of the screen.

3. Maximize the Application Window: (optional) Click the Maximize button in the upper right of the main window to increase the workspace to the maximum possible for your screen.

Maximized Workspace

Maximized Workspace


Weather Defender® - Desktop Weather Software for your PC. Weather Satellite, Weather Radar, and Street-Level Weather Tracking.



Images and text Copyright © 2008-2009 by SWIFT Weather. All rights reserved. ScrewTurn Wiki version 2.0.35. Administration | File Management