Weather Defender Documentation

Page History: Main Interface

Compare Page Revisions



« Older Revision - Back to Page History - Newer Revision »


Page Revision: 12/24/2008 11:39 AM


This page describes the main application interface including toolbars, buttons, and dialog windows in Weather Defender.


1 - Interface Overview

The main interface is divided up into four parts: toolbars, workspace, dialog windows, and status bar.

Interface Components

Interface Components


1.1 Toolbars

Most of the tools and options available to you are grouped according to function: Map, Team, Interface, and Help.

Map Tab

Map Tab

Map Tab


Team Tab

Team Tab

Team Tab


Interface Tab

Team Tab

Team Tab


Help Tab

Team Tab

Team Tab


Specialized Menus

Some options are available in the following specialized menus:

Shield Menu

The Shield Menu can be considered the "File Menu". It contains standard File Menu-type options as found in other Windows applications:

Shield Menu

Shield Menu

New Map

Open a new Map using the default template.

Open Map

Open a previously saved Map (*.map) from your computer.

Save Map

Save the currently open Map to your computer.

Save Map As

Save the currently open Map to a different location on your computer.

Close Map

Close the currently open Map without shutting down the application. If more than one Map is open, only the currently active (selected) Map will be closed.

Recent Maps

Listing of most recently opened maps. Click an item to open the Map.

Exit Application

Shutdown application.


Quick Access Toolbar

Quick Access Toolbar

Quick Access Toolbar


1.2 Workspace

1.3 Dialog Windows

Dialog Windows are the semi-transparent windows that appear over top of the workspace area. By default, only the Map Layers and Legend Dialog Windows will be shown. Taking certain actions in the application will cause other Dialog Windows to appear. For example, activating a GPS connection will cause the GPS Dialog Window to be displayed with status information.

There are five Dialog Windows in total: Map Layers, Map Legend, GPS, Chat, and Info Dialogs.

1.3.1 Map Layers Dialog Window

1.3.2 Map Legend Dialog Window

1.3.3 GPS Dialog Window

1.3.4 Chat Dialog Window

1.3.5 Info Dialog Windows

Info Dialogs are temporary pop-up windows that display when you click special icons on the map workspace. Certain data sets contain more details than can be displayed on-screen. For example, Storm Reports about snowfall would be displayed as a snowflake icon on the map. Clicking on this icon would pop-up an Info Dialog containing additional details (if any) such as total snowfall accumulation in the past 24 hours.

1.4 Status Bar

2 - Customizing the Interface

The interface is highly customizable and can be modified to suit your exact preferences.

2.1 Color & Themes

The application shell (main window) is black by default, but this theme can be changed to Blue or Silver using the Interface Tab > Theme options. You may further tint a selected theme using the color picker.

2.2 Dialog Window Placement

All Dialog Windows can be moved to any position on the Windows Desktop by left-clicking in the title area of the window and dragging, just as you would any other application in Windows. Dialog Windows will remain fixed at the position you drag them unless they are "snapped" to the border of the workspace area, in which case they will move with the main application whenever it is moved.

A Dialog Window may be "snapped" to the workspace area by dragging it within 5 pixels of the top, bottom, left, or right of the workspace edge.

Additionally, you may "dock" a Dialog Window to the top, bottom, left, or right of the workspace area to cause it to resize accordingly whenever the main application is resized. To "dock" a Dialog Window, first snap it to the desired corner of the workspace. Then resize the height (or width) of the dialog to the opposite corner of the workspace.

Dialog Window modifications will be stored when you exit the program so they will reappear in the same location the next time you start.

You may RESET all Dialog Window positions to their original locations by clicking Interface > Dialog Settings > Reset Positions.

2.3 Maximizing Workspace

If you are not frequently interacting with the map, it may be desirous to hide the parts of the interface and maximize the workspace (map) area.

Here's how:

1. Set the toolbar menu to auto-hide: Click the purple "Pin" button in the upper-right of the application. This will minimize the toolbars when not in use.

2. Make the Dialog Windows invisible: Click Interface Tab > Dialog Settings > Transparency. Move the slider to 10 or lower to make the Dialog Windows almost or entirely invisible when not in use. Now the Dialog Windows will only appear when you move your mouse into their region of the screen.

3. Maximize the Application Window: (optional) Click the Maximize button in the upper right of the main window to increase the workspace to the maximum possible for your screen.

Maximized Workspace

Maximized Workspace

Weather Defender® - Desktop Weather Software for your PC. Weather Satellite, Weather Radar, and Street-Level Weather Tracking.



Images and text Copyright © 2008-2009 by SWIFT Weather. All rights reserved. ScrewTurn Wiki version 2.0.35. Administration | File Management